CCNP
当前位置:首页 > 学习资料 > CCNP >

简单解说思科命令大全

更新时间:2021年05月31日   作者:spoto   标签(Tag):思科认证  

1. switch配置命令

(1)模式转换命令

用户模式----特权模式,使用命令"enable"
特权模式----全局配置模式,使用命令"configt"
全局配置模式----接口模式,使用命令"interface+接口类型+接口号"
全局配置模式----线控模式,使用命令"line+接口类型+接口号"

简单解说思科命令大全

(2)配置命令

show running config 显示所有的配置
show versin 显示版本号和寄存器值
shut down 关闭接口
no shutdown 打开接口
ip add +ip地址配置IP地址
secondary+IP地址为接口配置第二个IP地址
show interface+接口类型+接口号查看接口管理性
show controllers interface 查看接口是否有DCE电缆
show history 查看历史记录
show terminal 查看终端记录大小
hostname+主机名配置路由器或交换机的标识

2. 路由器配置命令

ip route+非直连网段+子网掩码+下一跳地址配置静态/默认路由
show ip route 查看路由表
show protocols 显示出所有的被动路由协议和接口上哪些协议被设置
show ip protocols 显示了被配置在路由器上的路由选择协议,同时给出了在路由选择协议中使用的定时器等信息
router rip 激活RIP协议
network +直连网段发布直连网段
interface lookback 0 激活逻辑接口
passive-interface +接口类型+接口号配置接口为被动模式
debug ip +协议动态查看路由更新信息
undebug all 关闭所有DEBUG信息

3. 三层交换机配置命令

配置一组二层端口

configure terminal 进入配置状态
nterface range {port-range} 进入组配置状态

配置三层端口

configureterminal 进入配置状态
interface {{fastethernet | gigabitethernet} interface-id} | {vlan vlan-id} |{port-channel port-channel-number} 进入端口配置状态
no switchport 把物理端口变成三层口
ip address ip_address subnet_mask 配置IP地址和掩码
no shutdown 激活端口

配置VLAN

configure terminal 进入配置状态
vlan vlan-id 输入一个VLAN号, 然后进入vlan配态,可以输入一个新的VLAN号或旧的来进行修改。
name vlan-name 可选)输入一个VLAN名,如果没有配置VLAN名,缺省的名字是VLAN号前面用0填满的4位数,如VLAN0004是VLAN4的缺省名字
mtu mtu-size (可选) 改变MTU大小

将端口分配给一个VLAN

configure terminal 进入配置状态
interface interface-id 进入要分配的端口
switchport mode access 定义二层口
switchport access vlan vlan-id 把端口分配给某一VLAN

配置VLAN trunk

configure terminal 进入配置状态
interface interface-Id 进入端口配置状态
switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封装ISL 或 802.1Q 或自动协商
switchport mode {dynamic {auto | desirable} | trunk} 配置二层trunk模式。
dynamic auto—自动协商是否成为trunk
dynamic desirable—把端口设置为trunk如果对方端口是trunk, desirable, 配置Native VLAN(802.1q) 或自动模式,trunk—设置端口为强制的trunk方式,而不理会对方端口是否为trunk
switchport access vlan vlan-id 可选) 指定一个缺省VLAN, 如果此端口不再是trunk
switchport trunk native vlan vlan-id 指定802.1Q native VLAN号

定义TRUNK允许的VLAN

configure terminal子进入配置状态
interface interface-id 进入端口配置
switchport mode trunk 配置二层口为trunk
switchport trunk allowed vlan {add | all | except | remove} vlan-list可选) 配置trunk允许的VLAN.使用add, all, except, remove关健字
no switchport trunk allowed vlan 允许所有VLAN通过

配置NativeVLAN(802.1q)

configure terminal 进入配置状态
interface interface-id 进入配置成802.1qtrunk的端口
switchport trunk native vlan vlan-Id 配置native VLAN号
no switchport trunk native vlan 端口配置命令回到缺省的状态

配置基于端口权值的负载均衡

configure terminal 进入Switch 1配置状态
vtp domain domain-name 配置VTP域
vtp mode server 将Switch 1配置成VTP server.
show vtp status 验证VTP的配置
show vlan 验证VLAN
configure terminal 进入配置状态
interface fastethernet 0/1 进入F0/1端口
switchport trunk encapsulation {isl | dot1q | negotiate}配置trunk封装
switchport mode trunk 配置成trunk
show interfaces fastethernet0/1 switchport 验证VLAN配置
按以上步骤对想要负载均衡的接口进行配置


对于思科命令大全就简单介绍到这里,更多思科命令相关内容以后会陆续给大家分享!
              马上抢免费试听资格
意向课程: *必选
姓名: *必填
联系方式: *必填
QQ:
思博SPOTO在线咨询

相关资讯

7天无条件退款
24小时实验室开放
全程跟踪服务
无条件免费重读

如在过程中遇到任何问题
欢迎在此填写反馈意见

官方公众号