当前位置: 首页 > CCNP > 简单解析单臂路由配置命令

简单解析单臂路由配置命令

img
李老师思科答疑老师
思博双IE金牌讲师
img
img
img
更新时间:2021年04月14日   作者:spoto | 单臂路由配置命令  
简单解析单臂路由配置命令:单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。

单臂路由配置命令

为什么要用到单臂路由

VLAN(虚拟局域网)技术是路由交换中非常基础的技术。在网络管理实践中,通过在交换机上划分适当数目的 vlan,不仅能有效隔离广播风暴, 还能提高网络安全系数及网络带宽的利用效率。
划分 vlan 之后,vlan 与 vlan 之间是不能通信的,只能通过路由或三层交换来实现。我们知道路由器实现路由功能通常是数据报从一个接口进来然后另一个接口出来, 现在路由器与交换机之间通过一条主干现实通信或数据转发, 也就是说路由器仅用一个接口实现数据的进与出, 因为我们形象地称它为单臂路由。单臂路由是解决 vlan 间通信的一种廉价而实用的解决方案。
在学习单臂路由的配置之前,建议大家先学好 VLAN,起码要知道 VLAN是怎么配置的,这样学单臂路由就轻松多了。

单臂路由配置实例

一、先把ip地址配置好

二、配置路由器子接口:

1、先启动接口:
2、命令如下:
Router(config)#interface fastEthernet 0/1.1
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastEthernet 0/1.2
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fastEthernet 0/1.3
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip address 192.168.30.1 255.255.255.0
Router(config-subif)#exit
Router(config)#

三、配置路由器下连的交换机

先配置三个vlan然后分别把三个网段加入到三个vlan中;
再设置与路由器相连的接口设为trunk模式,并且允许所有vlan通过!
命令如下:
Switch>
Switch>en
Switch#conf
Switch#configure t
Switch(config)#vlan 10
Switch(config-vlan)#name VLAN10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name VLAN20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#name VLAN30
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#sw
Switch(config-if)#switchport ac
Switch(config-if)#switchport access v
Switch(config-if)#switchport access vlan 10
Switch(config-if)#switchport mode access
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport access vlan 20
Switch(config-if)#switchport mode access
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/4
Switch(config-if)#switchport access vlan 30
Switch(config-if)#switchport mode access
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#exit
Switch(config)#

通过上述步骤,就配置完成了!怎么样,你学会了吗?

相关课程内容推荐 

 

思科认证备考须知:CCNP是什么

思博全新EI课程上架:CCNP-EI 课程

思博CCNP课程安排表: CCNP-EI课表

思科认证有什么用:ccnp考到工资一般多少

思科认证有效期多久:CCNP 重认证

思科认证要多少钱:ccnp培训费用多少钱?

 

热门推荐
最新推荐
客服 扫码咨询考证课程


即刻预约

免费试听-咨询课程-获取免费资料

思博网络SPOTO新活动 
-->