当前位置: 首页 > CCNA > CCNA实验手册 04——Router_on_a_stick

CCNA实验手册 04——Router_on_a_stick

客服
蔡老师思科答疑老师
思博金牌讲师
客服
客服
客服
更新时间:2018年11月20日   作者:spoto | CCNA实验  交换机vlan操作  广播域作用  

04-Router_on_a_stick - 需求

实验目的

  • 掌握交换机VLAN的基本操作
  • 理解广播域的作用

拓扑与需求

拓扑:

需求:

  1. 配置SW1和SW2的vlan和trunk实现PC1-PC3,PC2-PC4之间的通信
  2. 配置单臂路由实现所有PC之间的通信
 
 

04-Router_on_a_stick - 答案


 

配置与实现

 

 
1. 配置SW1和SW2的vlan和trunk实现PC1-PC3,PC2-PC4之间的通信

SW1

SW1(config)#interface ethernet0/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 10
% Access VLAN does not exist. Creating vlan 10
SW1(config-if)#interface ethernet0/2
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20
% Access VLAN does not exist. Creating vlan 20
SW1(config-if)#interface ethernet0/0
SW1(config-if)#switchport trunk encapsulation dot1q 
SW1(config-if)#switchport mode trunk

SW2

SW2(config)#interface ethernet0/1
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 10
% Access VLAN does not exist. Creating vlan 10
SW2(config-if)#interface ethernet0/2
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 20
% Access VLAN does not exist. Creating vlan 20
SW2(config-if)#interface ethernet0/0
SW2(config-if)#switchport trunk encapsulation dot1q 
SW2(config-if)#switchport mode trunk

 

 

2. 配置单臂路由实现所有PC之间的通信

 

 

配置PC网关

PC1 & PC3

PCX(config)#no ip routing
PCX(config)#ip default-gateway 192.168.10.254

PC2 & PC4

PCX(config)#no ip routing
PCX(config)#ip default-gateway 192.168.20.254

在单播中,当数据需要跨广播域/网段进行传输时,需要网关来进行转发
配置SW2 Trunk

SW2

SW2(config)#interface ethernet 0/3
SW2(config-if)#switchport trunk encapsulation dot1q 
SW2(config-if)#switchport mode trunk 

配置R1子接口,实现单臂路由

R1

R1(config)#interface ethernet 0/0
R1(config-if)#no shutdown  
R1(config-if)#interface ethernet 0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.254 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#interface ethernet 0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.254 255.255.255.0
R1(config-subif)#no shutdown 

相关课程内容推荐 

 

思科认证备考须知:CCNA 备考指南

思博全新思科课程399活动价限额限时优惠:新版CCNA 课程

思博CCNA课程安排表: CCNA课表

ccna考试报名:CCNA报名考试攻略预约流程

CCNA培训机构都学些什么:东莞CCNA培训机构有哪些?

 

热门推荐
最新推荐
bg
客服 扫码咨询考证课程


即刻预约

免费试听-咨询课程-获取免费资料

思博网络SPOTO新活动X