CCNA
当前位置:首页 > 学习资料 > CCNA >

CCNA实验手册 07——DHCP

更新时间:2018年11月21日   作者:spoto   标签(Tag):ccna  

07-DHCP - 需求

实验目的

  • 掌握Trunk的配置
  • 掌握VTP基本操作
  • 理解VTP角色之间的区别

拓扑与需求

拓扑:

需求:

1. MSW1和SW2之间的线路需配置为Trunk,采用Dot1q封装协议
2. MSW1和SW2上创建VLAN 10、20,MSW1 配置SVI 10的IP为192.168.10.254,SVI 20的IP为192.168.20.254,作为PC1和PC2的网关,SW2将接口E0/1划分到VLAN 10,E0/2划分到VLAN 20
3. 在MSW1上配置两个DHCP地址池,地址池名Produce,分发地址范围192.168.10.0/24,网关为192.168.10.254,DNS地址为114.114.114.114,要求下发IP地址时不允许下发192.168.10.254;地址池名Office,分发地址范围192.168.20.0/24,网关为192.168.20.254,DNS地址为114.114.114.114,要求下发IP地址时不允许下发192.168.20.254

07-DHCP - 答案


配置与实现

 

 
1. MSW1和SW2之间的线路需配置为Trunk,采用Dot1q封装协议

MSW1

MSW1(config)#interface ethernet 0/0
MSW1(config-if)#switchport trunk encapsulation dot1q 
MSW1(config-if)#switchport mode trunk 

SW2

SW2(config)#interface ethernet 0/0
SW2(config-if)#switchport trunk encapsulation dot1q 
SW2(config-if)#switchport mode trunk 

 

 
2. MSW1和SW2上创建VLAN 10、20,MSW1 配置SVI 10的IP为192.168.10.254,SVI 20的IP为192.168.20.254,作为PC1和PC2的网关,SW2将接口E0/1划分到VLAN 10,E0/2划分到VLAN 20

MSW1

MSW1(config)#vlan 10,20
MSW1(config-vlan)#interface vlan 10
MSW1(config-if)#ip address 192.168.10.254 255.255.255.0
MSW1(config-if)#no shutdown 
MSW1(config-if)#interface vlan 20
MSW1(config-if)#ip address 192.168.20.254 255.255.255.0
MSW1(config-if)#no shutdown 

SW2

SW2(config)#interface ethernet 0/1
SW2(config-if)#switchport mode access 
SW2(config-if)#switchport access vlan 10
% Access VLAN does not exist. Creating vlan 10
SW2(config-if)#interface ethernet 0/2
SW2(config-if)#switchport mode access 
SW2(config-if)#switchport access vlan 20
% Access VLAN does not exist. Creating vlan 20

 

 
3. 在MSW1上配置两个DHCP地址池,地址池名Produce,分发地址范围192.168.10.0/24,网关为192.168.10.254,DNS地址为114.114.114.114,要求下发IP地址时不允许下发192.168.10.254;地址池名Office,分发地址范围192.168.20.0/24,网关为192.168.20.254,DNS地址为114.114.114.114,要求下发IP地址时不允许下发192.168.20.254

MSW1

创建DHCP地址池

MSW1(config)#ip dhcp pool Produce
MSW1(dhcp-config)#network 192.168.10.0 /24
MSW1(dhcp-config)#default-router 192.168.10.254
MSW1(dhcp-config)#dns-server 114.114.114.114
MSW1(config)#ip dhcp pool Office
MSW1(dhcp-config)#network 192.168.20.0 /24                     
MSW1(dhcp-config)#default-router 192.168.20.254
MSW1(dhcp-config)#dns-server 114.114.114.114

移除不下发IP地址

MSW1(config)#ip dhcp excluded-address 192.168.10.254
MSW1(config)#ip dhcp excluded-address 192.168.20.254

PC1、PC2使用DHCP获取IP

PC1

PC1(config)#interface ethernet 0/1
PC1(config-if)#ip address dhcp
PC1(config-if)#no shutdown 

PC2

PC2(config)#interface ethernet 0/2
PC2(config-if)#ip address dhcp
PC2(config-if)#no shutdown 










              马上抢免费试听资格
意向课程: *必选
姓名: *必填
联系方式: *必填
QQ:
思博SPOTO在线咨询

相关资讯

7天无条件退款
24小时实验室开放
全程跟踪服务
无条件免费重读

如在过程中遇到任何问题
欢迎在此填写反馈意见