网工干货知识

超全学习笔记
当前位置:首页 > 干货知识

RIP路由协议

更新时间:2021年10月21日   作者:spoto   标签(Tag):

RIP路由协议

l 定期更新
l 依据传闻的更新,逐跳更新 (人家说什么信什么)
l 广播或组播更新整张路由表
l 在完全收敛之前,路由器无法正常工作
l 以跳数计算度量值的,度量值逐跳增加
l 并不了解网络拓扑
l 使用UDP协议,协议号17,端口号520
l RIPV1广播 255.255.255.255
l RIPV2 组播224.0.0.9
 

RIP六大防环机制

l 记数最大值(maximum hop count)
定义最大跳数(最大为15跳),当跳数为16跳时,目标为不可达。
l 水平分割(split horizon)
从一个接口学习到的路由不会再从该接口更新出去,cisco可以对每个接口关闭水平分割功能
l 路由中毒(route posion)
用于在发往其它路由器的路由更新中将路由标记为不可达
l 毒性逆转(poison reverse)
带毒性反转的“水平分割”规则规定,从特定接口向外发送更新时,将通过该接口获知的所有网络标 示为不可达
l 触发更新(trigger update)
一旦检测到拓扑变更,立即广播路由刷新报文,而不等到下一刷新周期
l 抑制定时器(Hold-down Time)
 

RIP定时器

RIP定时器

 

 

RIPv1跟RIPv2的区别

RIPv1跟RIPv2的区别

RIP V1默认的是自动汇总,不可手动开启和关闭。 RIP V2默认的是自动汇总,但是可以手动的开启和关闭。

 

 

 

 

基本配置

rip 基本配置

 

 

 

 

R1配置示例:

router rip //启动RIP 进程
version 2 //指定版本2
network 10.10.10.0 // 宣告需要宣告的网段,只能识别主类网络效果与10.0.0.0一样
network 192.168.1.0 // 宣告需要宣告的网段,只能识别主类网络效果与192.168.1.0一样
no auto-summary //关闭自动汇总 重要!!

 

 

 

 

R2配置示例:

router rip //启动RIP 进程
version 2 //指定版本2
network 10.10.10.0 // 宣告需要宣告的网段,只能识别主类网络效果与10.0.0.0一样
network 20.20.20 // 宣告需要宣告的网段,只能识别主类网络效果与183.62.0.0
no auto-summary //关闭自动汇总 重要!!

 

 

 

 

R3配置示例:

router rip //启动RIP 进程
version 2 //指定版本2
network 20.20.20.0 // 宣告需要宣告的网段,只能识别主类网络效果与20.0.0.0一样
network 183.62.61.0 // 宣告需要宣告的网段,只能识别主类网络效果与183.62.0.0
no auto-summary //关闭自动汇总 重要!!

默认版本是1.5,发 version1,接收 version1,2

 

 

 

network 作用:

1、使此IP所属的接口,参与路由协议进程。实际上就是使用IP地址范围,来确定哪些接口需要参与路由协议进程。
2、宣告此IP属于的网段,传递出去的子网掩码以接口配置的掩码为准。
3、RIP不支持精确宣告,只能支持主类网络宣告

 

 

 

手动汇总

rip 手动汇总

 

 

 

 

R1:

interface F0/0
ip summary-address rip 172.16.0.0 255.255.252.0 //手动汇总成22位
l 只有本地有明细路由(不管是你本地的,还是人家传给你的),才能进行汇总,明细路由全部消失,汇总路由才会消失。
l 汇总路由的度量值,以明细路由中最小的metric值作为汇总路由的度量值
l RIP无法进行超网汇总,例如172.0.0.0 255.0.0.0

这里的图有点错误,将下图中的路由条目当做拓扑图中的R3学到的就行,这里只是为了演示:汇总路由的度量值,以明细路由中最小的metric值作为汇总路由的度量值。

ip 验证显示-1

ip 验证显示-2

 

 

 

 

默认路由:

rip 默认路由

假设R3连接公网,那么R2,R1身上的用户访问公网,都需要默认路由。有没有一种办法,让默认路由自动传递,而不需要每台路由器上都去写默认路由。
(首先保证设备接口都被network宣告,这里只是演示下发默认路由。其他的接口该怎么宣告还怎么宣告,宣告了才能交互路由信息)

 

 

 

 

方法1:写一条出接口形式的默认路由

R3:
ip route 0.0.0.0 0.0.0.0 f0/1 必须是出接口(需要注意,在有些版本中出接口为loopback无效)
!
router rip
vesion 2
no auto-summary
network 0.0.0.0
在距离矢量路由协议中,所有以出接口形式存在的默认路由,都能够被通告,因为看的是路由条目

 

 

 

 

方法2:RIP协议下发

R3:
ip route 0.0.0.0 0.0.0.0 3.3.3.1,//下一跳,出接口都行,只要保证本地路由表中有默认路由
router rip
vesion 2
no auto-summary
default-information originate

 

 

 

 

方法3:重分布

R3:
ip route 0.0.0.0 0.0.0.0 3.3.3.1,下一跳,出接口都行,只要保证本地路由表中有默认路由
router rip
vesion 2
no auto-summary
redistribute static
 

 

 

 马上抢免费试听资格
意向课程: *必选
姓名: *必填
联系方式: *必填
QQ:
思博SPOTO在线咨询

相关资讯


即刻预约

免费试听-咨询课程-获取免费资料