网工干货知识

超全学习笔记
当前位置:首页 > 干货知识

EIGRP路由协议

更新时间:2021年10月21日   作者:spoto   标签(Tag):

EIGRP路由协议特点:

l CISCO私有协议 (混合路由选择协议,协议号88,组播地址224.0.0.10)
l 默认管理距离为90。
l 重分布(外部路由) 的路由的管理距离为170。
l 手动汇总的路由管理距离为5。
l 默认支持4条等价负载的链路,实现负载均衡的链路 (等价或不等价)最高达到16条
 

EIGRP三张表:

EIGRP三张表

 

 

邻居建立过程:

邻居建立过程

 

 

 

 

度量值计算:

度量值计算设计概念公式

度量值计算过程

 

 

 

 

 

EIGRP术语:

EIGRP术语

 

 

 

 

 

路径计算:

EIGRP路径计算

 

 

 

 

配置示例:

EIGRP配置示例

 

 

 

 

R1关键配置示例:

router eigrp 1 //同一个区域,必须配置同一个AS号,否则报错
network 1.1.1.1 0.0.0.255 //也可以按接口IP地址精确宣告
network 192.168.12.1 0.0.0.0 //这种就是精确宣告
network 192.168.13.1 0.0.0.0
no auto-summary //关闭自动汇总

 

 

 

 

R2关键配置示例:

router eigrp 1 //同一个区域,必须配置同一个AS号,否则报错
network 2.2.2.0 0.0.0.0
network 192.168.12.2 0.0.0.0
network 192.168.23.2 0.0.0.0
no auto-summary //关闭自动汇总

 

 

 

 

R3关键配置示例:

router eigrp 1 //同一个区域,必须配置同一个AS号,否则报错
network 3.3.3.3 0.0.0.0
network 192.168.13.3 0.0.0.0
network 192.168.23.3 0.0.0.0
no auto-summary

 

 

 

 

network 作用:

1、使此IP所属的接口,参与路由协议进程。实际上就是使用IP地址范围,来确定哪些接口需要参与路由协议进程。
2、宣告此IP属于的网段,传递出去的子网掩码以接口配置的掩码为准。
3、EIGRP可以支持精确宣告

 

 

 

 

反掩码:

子网掩码:255.255.255.0
反掩码:0.0.0.255
如何计算,使用255.255.255.255 减去子网掩码,就可以得到反掩码

子网掩码:
1 表示匹配,0表示任意

反掩码:
0 表示匹配,1表示任意

 

 

 

 

等价负载均衡:

l EIGRP在度量值相同的所有路径之间分配数据流量
l 默认为4条等价路径之间均衡负载,最大可支持16条
l (config-router)#maximum-paths (1-6) ,改为1,则负载均衡关闭
l 根据EIGRP度量值计算公式,只要带宽与延迟之和相同,就能实现等价路由
IGRP等价负载均衡

 

 

 

 

不等价负载均衡:

l EIGRP也可以在度量值不同的多条路径直接进行负载均衡
l 只有满足FC条件才能进行不等价负载均衡
l 需要负载FD<=最小FD * variance (修改后)
l (config-router)# Variance (1-128) 默认为1
l 注 : Variance只是用于一个乘积计算的数值
l 算法:可行后继路由器的FD除以 后继路由器的FD,取整 + 1, 即要实现非等价负载均衡的路由的FD除以后继路由的最优FD,得数取整数后加1

最小的FD:307200
要进行负载的FD:307456
307456 除以 307200=1.0008333333333333333333333333333
取整再加上1=2
307200乘以2=614400
只要其他FD小于614400,都可以进行不等价负载均衡
EIGRP不等价负载均衡

 

 

 

 

EIGRP手动汇总:

EIGRP手动汇总

l 手动汇总可以包括超网路由,并且可以在任意需要汇总的EIGRP路由器上配置。
l 路由表中至少含有一条该汇总路由的明细路由,汇总路由才会被通告
l 本地自动产生一条汇总null 0 的路由,用于防环,AD值为5
l ip summary-address eigrp进行汇总的路由,在本地路由器上默认AD = 5,而其他路由器上为90
l 通告出去的汇总路由metric值,由明细路由中,metric值最小的路由决定

老版本修改汇总路由AD:
int e0/0
ip summary-address eigrp 172.16.0.0 255.255.0.0 20

新版本修改汇总路由AD:
router eigrp 1
summary-metric 172.16.0.0/16 distance 20

 

 

 

 

EIGRP默认路由:

EIGRP默认路由

假设R3连接了公网,那么R2,R1身上的用户访问公网,都需要默认路由。有没有一种办法,让默认路由自动传递,而不需要每台路由器上都去写默认路由。
(首先保证设备都被network宣告,这里只是演示下发默认路由,其他的接口该怎么宣告还怎么宣告,宣告了才能起邻居,起了邻居才能传路由)

 

 

 

 

方法1:写一条出接口形式的默认路由

R3:
ip route 0.0.0.0 0.0.0.0 f0/1 必须是出接口(需要注意,在有些版本中出接口为loopback无效)
!
router eigrp 1
network 0.0.0.0 255.255.255.255
在距离矢量路由协议中,所有以出接口形式存在的默认路由,都能够被通告,因为看的是路由条目

 

 

 

 

方法2:接口下汇总

R3
interface F0/0
ip summary-address eigrp 1 0.0.0.0 0.0.0.0

 

 

 

 

方法3:重分布

R3:
ip route 0.0.0.0 0.0.0.0 3.3.3.1 下一跳,出接口都行,只要保证本地路由表中有默认路由
router eigrp 1
redistribute static
redistribute static metric 8000000 10 255 1 1514 //数据出接口的属性 带宽/延迟/可靠性/负载/MTU
同为EIGRP协议重分布,不需要指定metric
 

 

 

 马上抢免费试听资格
意向课程: *必选
姓名: *必填
联系方式: *必填
QQ:
思博SPOTO在线咨询

上一篇:RIP路由协议

下一篇:OSPF路由协议

相关资讯


即刻预约

免费试听-咨询课程-获取免费资料