网工干货知识

超全学习笔记
当前位置:首页 > 干货知识

PPPoE原理与配置案例

更新时间:2021年10月21日   作者:spoto   标签(Tag):

PPPOE技术:

PPP协议又由于其本身的特点在点对点广域网链路中被广泛应用,支持多协议、支持身份验证技术等等。
PPPoE技术可以理解为此二者的结合,在以太网链路上,继承PPP协议的众多优点,其中以身份验证技术最抢眼。
PPPoE提供通过简单桥接的接入服务器把一个网络的多个主机连接到远程接入服务器的功能
如今PPPoE技术已经被广泛应用在运营商接入,许多家庭宽带用户,都是使用PPPoE拨号上网
 

PPPOE数据帧:

PPPOE数据帧

 

 

PPPOE链路建立过程:

PPPOE链路建立过程

 

 

 

 

PPPOE配置:

PPPOE配置

 

 

 

 

PPPOE Server R2配置示例:

username CISCO password 0 CISCO

ip dhcp pool CISCO
network 23.1.1.0 255.255.255.0
default-router 23.1.1.2

bba-group pppoe global //全局一定要敲!
virtual-template 1

interface Virtual-Template1
ip address 23.1.1.2 255.255.255.0
ip mtu 1492
peer default ip address dhcp-pool CISCO
ppp authentication pap
!
interface Ethernet0/0
no ip address
pppoe enable group global //接口记得关联
!

 

 

 

 

PPPOE Client R3配置示例:

interface Dialer0
ip address dhcp
ip mtu 1492
encapsulation ppp
dialer pool 1 //定义拨号编号为1
ppp pap sent-username CISCO password 0 CISCO
!
interface Ethernet0/0
no ip address
pppoe enable
pppoe-client dial-pool-number 1 //定义为PPPOE客户端,并且调用 dialer pool 1
!

 

 

 

 

动态产生默认路由(可选):

interface Dialer0
ppp ipcp route default
 

 

 

 马上抢免费试听资格
意向课程: *必选
姓名: *必填
联系方式: *必填
QQ:
思博SPOTO在线咨询

相关资讯


即刻预约

免费试听-咨询课程-获取免费资料