网工干货知识

思科实验手册
当前位置:首页 > 干货知识

单臂路由

更新时间:2021年10月18日   作者:spoto   标签(Tag):

一、实验难度

✅CCNA
CCNP
CCIE

 

 

二、实验目的

掌握单臂路由的原理及配置的基本命令
实现不同VLAN之间的互联互通

 

 

 

 

三、拓扑


单臂路由实验拓扑图

 

 

 

 

四、需求

1.按照图示给PC1、PC2配置IP地址
2.在sw1上创建VLAN,把端口划分不同的VLAN
3.在sw1上将连接Router的接口属性改为trunk,并允许VLAN 10、VLAN20通过
4.在Router上将连接sw1的接口开启子接口,分别作为VLAN 10和VLAN20的网关,绑定对应VLAN
5.验证PC1 ping PC2的连通性

 

 

 

 

五、配置与实现

 

 

1. 按照图示给PC1、PC2配置IP地址

PC1>enable
PC1#configure terminal
PC1(config)#no ip routing
PC1(config)#interface e0/0
PC1(config-if)#ip address 192.168.10.10 255.255.255.0
PC1(config-if)#no shutdown
PC2>enable
PC2#configure terminal
PC2(config)#no ip routing
PC2(config)#interface e0/0
PC2(config-if)#ip address 192.168.20.20 255.255.255.0
PC2(config-if)#no shutdown

 

 

2. 在SW1创建VLAN,把端口划分到不同的VLAN

Switch>enable
Switch#configure terminal
Switch(config)#hostname SW1
SW1(config)#vlan 10,20
SW1(config-vlan)#exit
SW1(config)#interface e0/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 10
SW1(config-if)#interface e0/2
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20

查看vlan
把端口划分到不同的VLAN

 

 

 

 

3.SW1交换机连接到路由器Router的E0/0接口配置为trunk口,并允许VLAN 10和VLAN 20通过

SW1(config)#interface Ethernet0/0
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport trunk allowed vlan 10,20

查看trunk
SW1交换机连接到路由器Router的E0/0接口配置为trunk口

 

 

 

 

4. 在Router上,将连接SW1的e0/0接口创建两个子接口,分别作为VLAN 10和VLAN20的网关

  每个子接口必须封装dot1Q协议,并且标记相应的vlan id号,dot1Q协议主要是标记vlan的id号
  每个子接口必须配置ip地址,而且该接口的ip地址必须和相应的vlan的在同一个网段

Router>enable
Router#configure terminal
Router(config)#interface Ethernet0/0
Router(config-if)#no shutdown
Router(config)#interface e0/0.1
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.254 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#exit
Router(config)#interface e0/0.2
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.254 255.255.255.0
Router(config-subif)#no shutdown

 

 

 

 

5. 验证PC1 ping PC2的连通性

验证PC1的连通性

验证ping PC2的连通性

 

 

 

 

 马上抢免费试听资格
意向课程: *必选
姓名: *必填
联系方式: *必填
QQ:
思博SPOTO在线咨询

上一篇:SVI

下一篇:PAGP

相关资讯


即刻预约

免费试听-咨询课程-获取免费资料