网工干货知识

思科实验手册
当前位置:首页 > 干货知识

静态路由与默认路由

更新时间:2021年10月19日   作者:spoto   标签(Tag):

一、实验难度

✅CCNA
CCNP
CCIE

 

 

二、实验目的

掌握静态路由原理及配置
掌握默认路由原理及配置
了解路由递归原理
了解路由选路规则

 

 

 

 

三、拓扑


静态路由与默认路由实验拓扑图

 

 

 

 

四、需求

1.PC1在LAN1中,PC2在LAN2中,配置静态路由实现两个LAN中的PC能够通信,路径:PC1-R1-R2-R3-PC3;
2.将R1的e0/1接口shutdown,观察R1静态路由是否失效;
3.在R1、R3之间配置默认路由实现两个LAN中的PC能够通信,路径:PC1-R1-R3-PC2;
4.恢复之前关闭的接口,观察同时存在明细静态路由和默认路由时,设备会使用哪个路由条目转发报文。

 

 

 

 

五、配置与实现

 

 

1. 配置静态路由实现两个LAN中的PC能够通信

PC1:
Router>enable
Router#configure terminal
Router(config)#hostname PC1
PC1(config)#no ip routing //因为使用路由器模拟PC,所以需要关闭设备路由功能。
PC1(config)#interface ethernet 0/0
PC1(config-if)#ip address 192.168.10.1 255.255.255.0
PC1(config-if)#no shutdown
PC1(config-if)#exit
PC1(config)#ip default-gateway 192.168.10.254 //设置PC网关。

PC2:
Router>enable
Router#configure terminal
Router(config)#hostname PC2
PC2(config)#no ip routing //因为使用路由器模拟PC,所以需要关闭设备路由功能。
PC2(config)#interface ethernet 0/0
PC2(config-if)#ip address 192.168.20.1 255.255.255.0
PC2(config-if)#no shutdown
PC2(config-if)#exit
PC2(config)#ip default-gateway 192.168.20.254 //设置PC网关。

R1:
Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface ethernet 0/0
R1(config-if)#ip address 192.168.10.254 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface ethernet 0/1
R1(config-if)#ip address 12.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip route 192.168.20.0 255.255.255.0 12.1.1.2 //配置去往LAN2的静态路由

R2:
Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface ethernet 0/1
R2(config-if)#ip address 12.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface ethernet 0/0
R2(config-if)#ip address 23.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#ip route 192.168.10.0 255.255.255.0 12.1.1.1 //配置去往LAN1的静态路由
R2(config)#ip route 192.168.20.0 255.255.255.0 23.1.1.3 //配置去往LAN2的静态路由

R3:
Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#interface ethernet 0/0
R3(config-if)#ip address 23.1.1.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface ethernet 0/1
R3(config-if)#ip address 192.168.20.254 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#ip route 192.168.10.0 255.255.255.0 ethernet 0/0 //配置去往LAN1的静态路由,出接口为e0/0

查看R1-R3路由表项是否正常:
查看R1路由表项是否正常

查看R2路由表项是否正常

查看R3路由表项是否正常

验证PC1与PC2之间是否能够进行通信:
验证PC1与PC2之间是否能够进行通信


跟踪报文转发路径:
跟踪报文转发路径


PC1与PC2能够正常进行通信,且路径符合需求,说明静态路由配置下一跳和出接口能够实现相同效果。

 

 

2、将R1的e0/1接口shutdown,观察R1静态路由是否失效

R1:
R1(config)#interface ethernet 0/1
R1(config-if)#shutdown

R1的e0/1接口shutdown之后查看R1路由表项,发现静态路由192.168.20.0/24失效:
R1的e0/1接口shutdown之后查看R1路由表项



静态路由是否失效取决于静态路由的下一跳是否可达,R1去往LAN2 192.168.20.0/24的下一跳为12.1.1.2,将R1的e0/1接口关闭意味着接口的直连路由12.1.1.0/24消失,所以静态路由失效。这里涉及路由递归查询问题。

 

 

 

 

3、在R1、R3之间配置默认路由实现两个LAN中的PC能够通信

R1:
R1(config)#interface ethernet 0/2
R1(config-if)#ip address 13.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 13.1.1.3 //配置去往LAN2的默认路由

R3:
R3(config)#interface ethernet 0/2
R3(config-if)#ip address 13.1.1.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#ip route 0.0.0.0 0.0.0.0 13.1.1.1 //配置去往LAN1的默认路由
R3(config)#interface ethernet 0/0
R3(config-if)#shutdown //关闭R3的e0/0接口,防止回程报文从e0/0接口出去

查看R1、R3路由表项是否正常:
查看R1路由表项是否正常

查看R3路由表项是否正常

验证PC1与PC2之间是否能够进行通信:
验证PC1与PC2之间是否能够进行通信


跟踪报文转发路径:
跟踪报文转发路径

 

 

 

 

4. 恢复之前关闭的接口,观察同时存在明细静态路由和默认路由时,设备会使用哪个路由条目转发报文。

R1:
R1(config)#interface ethernet 0/1
R1(config-if)#no shutdown

R1:
R3(config)#interface ethernet 0/0
R3(config-if)#no shutdown

查看R1、R3路由表项:
查看R1路由表项

查看R3路由表项


跟踪报文转发路径,观察同时存在明细静态路由和默认路由时,设备会使用哪个路由条目转发报文:
跟踪报文转发路径


可以发现,报文转发路径为PC1-R1-R2-R3-PC2,说明设备使用明细的静态路由进行报文转发。这里涉及设备选路规则:最长掩码匹配。

 

 

 

 

六、思考

通过本实验我们可以学习到:
1、静态路由是否生效取决于下一跳是否可达(路由递归)。
2、当设备同时存在多条路由可以到达同一目的时,设备会使用掩码最长的路由进行报文转发(最长掩码匹配规则)。
3、静态路由配置下一跳和出接口在原理上有何区别?请参考代理ARP(proxy-arp)
 

 

 

 马上抢免费试听资格
意向课程: *必选
姓名: *必填
联系方式: *必填
QQ:
思博SPOTO在线咨询

上一篇:LACP

下一篇:最后一页

相关资讯


即刻预约

免费试听-咨询课程-获取免费资料