网工干货知识

网工技术实战
当前位置:首页 > 干货知识

交换机MUX VLAN配置示例

更新时间:2021年11月04日   作者:spoto   标签(Tag):

1、MUX VLAN产生背景

MUX VLAN(Multiplex VLAN)提供了一种通过VLAN进行网络资源控制的机制。例如,在企业网络中,企业员工和企业客户可以访问企业的服务器。对于企业来说,希望企业内部员工之间可以互相交流,而企业客户之间是隔离的,不能够互相访问。

为了实现所有用户都可访问企业服务器,可通过配置VLAN间通信实现。如果企业规模很大,拥有大量的用户,那么就要为不能互相访问的用户都分配VLAN,这不但需要耗费大量的VLAN ID,还增加了网络管理者的工作量同时也增加了维护量。通过MUX VLAN提供的二层流量隔离的机制可以实现企业内部员工之间互相交流,而企业客户之间是隔离的。
 

2、基本概念

MUX VLAN分为Principal VLAN和Subordinate VLAN,Subordinate VLAN又分为Separate VLAN和Group VLAN。

(1)Principal VLAN(主VLAN)

Principal port可以和MUX VLAN内的所有接口进行通信。
 

(2)Subordinate VLAN(从VLAN)

Separate VLAN(隔离型从VLAN):Separate port只能和Principal port进行通信,和其他类型的接口实现完全隔离。每个Separate VLAN必须绑定一个Principal VLAN。
Group VLAN(互通型从VLAN):Group port可以和Principal port进行通信,在同一组内的接口也可互相通信,但不能和其他组接口或Separate port通信。每个Group VLAN必须绑定一个Principal VLAN。
 

3、配置示例

1)组网需求

如图所示,在企业网络中,企业所有员工都可以访问企业的服务器。但对于企业来说,希望企业内部部分员工之间可以互相交流,而部分员工之间是隔离的,不能够互相访问。为了解决上述问题,可在连接终端的交换机上部署MUX VLAN(复合vlan)特性。MUX VLAN不但能够实现企业需求,同时也解决了VLAN ID紧缺问题,也便于网络管理者维护。
组网需求

2)配置思路

配置主VLAN的MUX-VLAN功能。
配置Group-VLAN功能。
配置Separate-VLAN功能。
配置接口加入VLAN并使能MUX-VLAN功能。

(3)

3)操作步骤

# 创建VLAN2、VLAN3和VLAN4。
system-view
[HUAWEI] sysname Switch
[Switch] vlan batch 2 3 4

# 配置MUX VLAN中的Group VLAN和Separate VLAN。
[Switch] vlan 2
[Switch-vlan2] mux-vlan
[Switch-vlan2] subordinate group 3
[Switch-vlan2] subordinate separate 4
[Switch-vlan2] quit

# 配置接口加入VLAN并使能MUX VLAN功能。
[Switch] interface gigabitethernet 1/0/1
[Switch-GigabitEthernet1/0/1] port link-type access
[Switch-GigabitEthernet1/0/1] port default vlan 2
[Switch-GigabitEthernet1/0/1] port mux-vlan enable vlan 2
[Switch-GigabitEthernet1/0/1] quit
[Switch] interface gigabitethernet 1/0/2
[Switch-GigabitEthernet1/0/2] port link-type access
[Switch-GigabitEthernet1/0/2] port default vlan 3
[Switch-GigabitEthernet1/0/2] port mux-vlan enable vlan 3
[Switch-GigabitEthernet1/0/2] quit
[Switch] interface gigabitethernet 1/0/3
[Switch-GigabitEthernet1/0/3] port link-type access
[Switch-GigabitEthernet1/0/3] port default vlan 3
[Switch-GigabitEthernet1/0/3] port mux-vlan enable vlan 3
[Switch-GigabitEthernet1/0/3] quit
[Switch] interface gigabitethernet 1/0/4
[Switch-GigabitEthernet1/0/4] port link-type access
[Switch-GigabitEthernet1/0/4] port default vlan 4
[Switch-GigabitEthernet1/0/4] port mux-vlan enable vlan 4
[Switch-GigabitEthernet1/0/4] quit
[Switch] interface gigabitethernet 1/0/5
[Switch-GigabitEthernet1/0/5] port link-type access
[Switch-GigabitEthernet1/0/5] port default vlan 4
[Switch-GigabitEthernet1/0/5] port mux-vlan enable vlan 4
[Switch-GigabitEthernet1/0/5] quit
 

4)检查配置结果

4.1、Server和HostB、HostC、HostD、HostE在同一网段。
4.2、Server和HostB、HostC、HostD、HostE二层流量互通。
4.3、HostB和HostC二层流量互通。
4.4、HostD和HostE二层流量不通。
4.5、HostB、HostC和HostD、HostE二层流量不通。
 

5)配置文件

Switch的配置文件
#
sysname Switch
#
vlan batch 2 to 4
#
vlan 2
mux-vlan
subordinate separate 4
subordinate group 3
#
interface GigabitEthernet1/0/1
port link-type access
port default vlan 2
port mux-vlan enable vlan 2
#
interface GigabitEthernet1/0/2
port link-type access
port default vlan 3
port mux-vlan enable vlan 3
#
interface GigabitEthernet1/0/3
port link-type access
port default vlan 3
port mux-vlan enable vlan 3
#
interface GigabitEthernet1/0/4
port link-type access
port default vlan 4
port mux-vlan enable vlan 4
#

interface GigabitEthernet1/0/5
port link-type access
port default vlan 4
port mux-vlan enable vlan 4
#
return

 

 

 

 马上抢免费试听资格
意向课程: *必选
姓名: *必填
联系方式: *必填
QQ:
思博SPOTO在线咨询

相关资讯

7天无条件退款
24小时实验室开放
全程跟踪服务
无条件免费重读

如在过程中遇到任何问题
欢迎在此填写反馈意见

思博网络SPOTO官方公众号

官方公众号

思博网络SPOTO新活动