网工干货知识

超全学习笔记
当前位置:首页 > 干货知识

企业网络冗余技术(EthernetChannel、HSRP、VRRP)

更新时间:2021年10月20日   作者:spoto   标签(Tag):

EthernetChannel(802.3ad)

将两个设备间多条相同特性的快速以太或千兆位以太物理链路捆绑在一起组成一条逻辑链路,从而达到带宽倍增及负载均衡的目的。
EthernetChannel(802.3ad)


配置要点:
Port-channel接口一旦建立完成,就形成了一个逻辑接口,后续针对接口的配置,都在Port-channel接口中完成。
Port-channel接口不能成为SPAN(端口镜像)的目的接口。
隶属于同一个Port-channel的物理接口需有相同的如下配置:
1、端口之间的Speed 和Duplex需相同( LACP只能是全双工模式 )
2、接口模式相同(Trunk 、access)。
3、Trunk模式的Native vlan 和 Allowed vlan 需相同。
4、Aeecss模式 的所属Vlan 需相同。
 

二层捆绑口配置

interface port-channel 1
switchport
switch trunk encapsulation dot1q
switchport mode trunk
!
interface range e0/1 – 2
shutdown //为了避免出现BUG,先将物理接口shutdown,然后配置封装模式,最后加入捆绑
switchport
switch trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on
no shutdown
 

三层捆绑口配置:

interface Port-channel12
no switchport
ip address 12.1.1.2 255.255.255.0
end

interface Ethernet0/1-2
shutdown
no switchport
no ip address
channel-group 12 mode on
no shutdown

 

HSRP(CISCO私有协议)

Hello包是通过组播地址224.0.0.2发送
UDP协议,1985端口,Hello时间3S,死亡时间10S

HSRP的虚拟MAC地址

0000.0c07.acxx0000.0c为厂商编号07ac为 HSRP编号xx为HSRP组
 

HSRP几个术语:

HSRP路由器:运行HSRP的路由器,一台HSRP路由器(的接口)可以时参与州多个HSRP组中,在不同的组中,一台HSRP路由丞可以充当不同的角色.
HSRP group:由多个HSRP路由器组成,星于同一HSRP组的HSRP路由器互相交换信息,每一组由一个组ID进行标识。
HSRP虑教路由器:对于每一个HSRP组,换象出柬的一个逻辑路由器,该路由器竞当网络用户的网关
虑列IP地址、MAC地址:该地址实际上就是用户的默认网关,MAC地址为虚拟的;虚拟IP地址,不能与HSRP成员的实际IP地址一致;0000.0c07.acxx的保留MAC作为虚拟路由器的MAC,其中xx是该HSRP组的组ID
Active路由器:在HSRP组实际转发数据包的路由器,在每一个HSRP组中,仅有Active响应对虚斑IP地址的ARP请求。
Standby路由器:就是在HSRP组中处于氢斯状态的路由器,一EActive路由器出现故障,Standby路由本就开始接替工作。
主备选举规则:通过组播地址(224.0.0.2)发送hello包进行优先煅的选举,优先级高,则为活动路由器,低则为备份路由器,默认优先级为100,范围是0-255,如果优先级一致,则实际I地址天的成为活动路由器。

 

 

HSRP的Preempt机制

当检测到Active路由器失效的时候,Standby路由器在Hold down时间超时后,进行抢占,成为Active路由器,但HSRP抢占默认关闭,如果活动路由器挂掉之后又UP了,它不会进行抢占。
默认为立即抢占,可使用standby 1 preempt delay*(毫秒)更改,因为运行了动态路由协议,收敛需要时间,立即抢占回去会导致丢包。建议在Active上配置。

 

 

 

 

HSRP的 Track机制

HSRP无法感知上行链路的状态,如果上行链路断开,依然会造成网络故障,因此定义一个被监控的接口,这个接口一般是连接上联设备的那个本地接口,并配置一个惩罚数值(默认为10),如果连接上联设备的本地接口出现故障,则让出主动权,成为Standby 路由器。

也可以追踪对象: track 1 interface fastEthernet 1/0 line-protocol

 

 

 

 

HSRP配置案例:

SW1
no ip cef
interface vlan 10
ip address 192.168.10.1 255.255.255.0
standby 10 ip 192.168.10.254
standby 10 priority 110 //默认优先级100
standby 10 preempt //默认关闭抢占


SW2
no ip cef
interface vlan 10
ip address 192.168.10.2 255.255.255.0
standby 10 ip 192.168.10.254
standby 10 preempt

组编号要一致,不然会报错

 

 

 

 

配置链路检测(可选,不同IOS版本有配置差异):

track 10 interface Ethernet0/0 line-protocol
!
interface vlan 10
standby 10 track 10 decrement 20
老版本命令:
interface vlan 10
standby 1 track e0/1 20
!

 

 

 

 

VRRP(公有协议)

组播地址224.0.0.18
vrrp的虚拟MAC地址
0000.5E00.01 xx其中:0000.5E 由IANA分配00.01是VRRP编号xx代表VRRP组号
vrrp的虚拟MAC地址


R1:
interface f0/0
ip add 192.168.1.253 255.255.255.0
vrrp 10 ip 192.168.1.253 //配置组10虚拟IP,可以与实际IP相同
vrrp 10 priorty 110 //配置优先级,(默认为100)
vrrp 10 preemet //默认开启抢占

R2:
interface f0/0
ip add 192.168.1.252 255.255.255.0
vrrp 10 ip 192.168.1.253
vrrp 10 preemet
两端组编号要一致,不然会报错

 

 

 

 

配置链路检测(可选,不同IOS版本有配置差异):

track 10 interface Ethernet0/0 line-protocol
!
interface f0/0
vrrp 10 track 10 decrement 20
老版本命令:
interface f0/0
vrrp 10 track e0/1 20
!

 

 

 

 

VRRP/HSRP负载案例分享

多组HSRP,单臂路由+可网管交换机:

多组HSRP,单臂路由+可网管交换机 R1配置
多组HSRP,单臂路由+可网管交换机 R2配置



多组HSRP,三层交换机:
多组HSRP,三层交换机

 

 

 

 

 马上抢免费试听资格
意向课程: *必选
姓名: *必填
联系方式: *必填
QQ:
思博SPOTO在线咨询

相关资讯

7天无条件退款
24小时实验室开放
全程跟踪服务
无条件免费重读

即刻预约

免费试听-咨询课程-获取免费资料

思博网络SPOTO新活动