网工干货知识

超全学习笔记
当前位置:首页 > 干货知识

GRE VPN原理与配置案例

更新时间:2021年10月21日   作者:spoto   标签(Tag):

GRE VPN(Generic Routing Encapsulation):

通用路由封装协议GRE协议,它提供了将一种协议的报文封装在另一种协议报文中的机制,使报文能够在tunnel(隧道)中传输。
 

优点:

l 支持多种协议和多播
l 能够用来创建弹性的VPN
l 支持多点隧道
 

缺点:

l 缺乏加密机制
l 没有标准的控制协议来保持GRE隧道(通常使用协议和keepalive)
l 隧道很消耗CPU
l 出现问题要进行DEBUG很困难
l MTU和IP分片是一个问题
 

隧道技术(Tunnel):

Tunnel 是一个虚拟的点对点的连接,提供了一条通路使封装的数据报文能够在这个通路上传输,并且在一个Tunnel 的两端分别对数据报进行封装及解封装。
 

GRE包头格式:

GRE包头格式

 

 

配置案例:


GRE配置案例

1、R2、R3运行GRE VPN
2、R2、R3启用EIGRP协议
3、PC1、PC2通信走GRE隧道
IP地址配置过程与不再赘述

 

 

 

 

R2配置示例:

interface Ethernet0/0
ip address 12.1.1.2 255.255.255.0
!
interface Tunnel0
tunnel mode gre ip //默认封装
ip address 172.16.1.2 255.255.255.0
tunnel source Ethernet0/0 //也可写IP
tunnel destination 13.1.1.3
!
router eigrp 1
network 172.16.1.2 0.0.0.0
network 192.168.1.254 0.0.0.0

 

 

 

 

R3配置示例:

interface Ethernet0/1
ip address 13.1.1.3 255.255.255.0
!
interface Tunnel0
tunnel mode gre ip
ip address 172.16.1.3 255.255.255.0
tunnel source Ethernet0/0
tunnel destination 12.1.1.2
!
router eigrp 1
network 172.16.1.3 0.0.0.0
network 192.168.2.254 0.0.0.0
no auto-summary
 

 

 

 马上抢免费试听资格
意向课程: *必选
姓名: *必填
联系方式: *必填
QQ:
思博SPOTO在线咨询

上一篇:PPPoE原理与配置案例

下一篇:最后一页

相关资讯

7天无条件退款
24小时实验室开放
全程跟踪服务
无条件免费重读

即刻预约

免费试听-咨询课程-获取免费资料

思博网络SPOTO新活动